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Introduction

In 2007, Apple introduced the Apple ProRes codec family, providing an 
unparalleled combination of real-time, multistream editing performance, 
impressive image-quality preservation, and reduced storage rates for 
high-bit-depth 4:2:2 and 4:4:4:4 video.

Apple ProRes RAW is based on the same principles and underlying 
technology as existing ProRes codecs, but is applied to a camera 
sensor’s pristine raw image data rather than conventional image 
pixels. ProRes RAW brings to raw video the same great performance, 
quality, and ease of use that ProRes has brought to conventional video, 
in a format ideal for high-dynamic-range (HDR) content creation in 
Final Cut Pro X.
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Digital camera sensors consist of an array of millions of light-sensitive 
elements called photosites that convert the light exposed to the sensor 
to an array of digital intensity values. To capture color, most current 
digital cameras use a color filter array that yields a single primary color 
value (such as red, green, or blue) at each photosite location. This color 
filter arrangement is known as a Bayer pattern, where each two-by-two 
group of photosites consists of one red, one blue, and two green sensor 
elements. In contrast, conventional RGB images consist of not one but 
three primary color values (red, green, and blue) at each pixel location.
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About Raw Video

The process of converting a Bayer pattern image to a conventional RGB 
image is known as demosaicing. For conventional video, demosaicing 
and other processing operations are performed within the camera to 
produce viewable RGB images that can be recorded into a video file.
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At playback time, an application needs only to decode the conventional 
video file to produce RGB images that can be edited and displayed. The 
demosaicing and processing have already been performed by the camera 
at capture time and are “burned in.”

In contrast, ProRes RAW directly encodes the Bayer pattern image. 
Demosaicing and processing are deferred to the time of playback and 
are performed by application software.
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This requires more computation during playback but allows for greater 
flexibility. Just as different image and video codecs must make tradeoffs 
between compression rate, quality, and complexity, demosaicing 
algorithms must make tradeoffs between speed, quality, and other 
factors. Using ProRes RAW lets you defer the choice of demosaicing 
algorithm until post-production and allows you to take advantage of raw 
processing enhancements and demosaicing algorithm improvements in 
future software.
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Data Rate

ProRes RAW is available at two compression levels: Apple ProRes RAW 
and Apple ProRes RAW HQ. Both achieve excellent preservation of 
raw video content, with additional quality available at the higher data 
rate of Apple ProRes RAW HQ. Compression-related visible artifacts 
are very unlikely with Apple ProRes RAW, and extremely unlikely with 
Apple ProRes RAW HQ.

As is the case with existing ProRes codecs, the data rates of 
ProRes RAW are proportional to frame rate and resolution. ProRes RAW 
data rates also vary according to image content, but to a greater degree 
than ProRes data rates.

With most video codecs, including the existing ProRes family, a 
technique known as rate control is used to dynamically adjust 
compression to meet a target data rate. This means that, in practice, 
the amount of compression—hence quality—varies from frame to frame 
depending on the image content. In contrast, ProRes RAW is designed to 
maintain constant quality and pristine image fidelity for all frames. As a 
result, images with greater detail or sensor noise are encoded at higher 
data rates and produce larger file sizes.
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Data Rate

ProRes RAW data rates benefit from encoding Bayer pattern images 
that consist of only one sample value per photosite. Apple ProRes RAW 
data rates generally fall between those of Apple ProRes 422 and 
Apple ProRes 422 HQ, and Apple ProRes RAW HQ data rates generally 
fall between those of Apple ProRes 422 HQ and Apple ProRes 4444, as 
shown in the chart below.
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Performance

Like the existing ProRes codec family, ProRes RAW is designed for 
speed. Despite the additional computational demands of raw video 
editing, ProRes RAW brings to raw video the same first-rate performance 
and ease of editing that ProRes has brought to conventional video.

Raw video playback requires not only decoding the video bitstream 
but also demosaicing the decoded raw image. Final Cut Pro includes a 
streamlined and GPU-optimized demosaicing algorithm designed to meet 
the performance demands of real-time, multistream video editing.
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Performance

The following chart shows the number of full-quality 4K streams 
that can be played simultaneously for Apple ProRes RAW HQ and 
Apple ProRes RAW on a 28-core Mac Pro. Apple ProRes 4444 and 
Apple ProRes 422 HQ are included for comparison.
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Testing conducted by Apple in December 2019 on preproduction 2.5GHz 28-core Intel Xeon W-based
Mac Pro systems with 192GB of RAM and dual AMD Radeon Pro Vega II graphics with Infinity Fabric Link
and 32GB of HBM2 each, configured with Afterburner and a 4TB SSD. Tested on macOS Catalina with 
Final Cut Pro 10.4.7, using 1-minute picture-in-picture projects with 12 streams of Apple ProRes RAW 
video, 12 streams of Apple ProRes RAW HQ video, 11 streams of Apple ProRes 422 HQ video, and
5 streams of Apple ProRes 4444 video, all at 4096x2160 resolution and 59.94 frames per second. 
Performance may vary based on system configuration, media type, and other factors.

Number of simultaneous 4K streams

ProRes RAW also supports accelerated reduced-resolution decoding 
modes that are used in the Final Cut Pro Better Performance playback 
setting for even greater performance and responsiveness.
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Testing conducted by Apple in December 2019 on preproduction 2.4GHz 8-core Intel Core i9-based
16-inch MacBook Pro systems with 64GB of RAM, Radeon Pro 5500M graphics with 8GB of VRAM, and 
a 4TB SSD. Tested on macOS Catalina with Final Cut Pro 10.4.7, using 1-minute picture-in-picture 
projects with 6 streams of Apple ProRes RAW video and 5 streams of Apple ProRes RAW HQ video,
all at 4096x2160 resolution and 59.94 frames per second. Performance may vary based on system 
configuration, media type, and other factors.

Number of simultaneous 4K streams
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Performance

Compared to other raw video formats supported by Final Cut Pro, 
ProRes RAW offers superior performance in both playback and 
rendering, as shown in the charts below.
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Testing conducted by Apple in November 2019 on preproduction 2.5GHz 28-core Intel Xeon W-based
Mac Pro systems with 384GB of RAM and dual AMD Radeon Pro Vega II graphics with Infinity Fabric Link 
and 32GB of HBM2 each, configured with Afterburner and a 4TB SSD. Tested on macOS Catalina, with
Final Cut Pro 10.4.7, Canon RAW Plugin 1.1.2 for Final Cut Pro X, and plug-ins from RED Apple Workflow 
Installer v14, using 50-second picture-in-picture projects with 33 streams of Apple ProRes RAW video,
33 streams of Apple ProRes RAW HQ video, 3 streams of Canon Cinema RAW Light video, 2 streams
of REDCODE® RAW 5:1 video, and 1 stream of REDCODE® RAW 3:1 video, all at 4096x2160 resolution 
and 23.98 frames per second. Performance may vary based on system configuration, media type, and 
other factors.
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Testing conducted by Apple in November 2019 on preproduction 2.5GHz 28-core Intel Xeon W-based 
Mac Pro systems with 384GB of RAM and dual AMD Radeon Pro Vega II graphics with Infinity Fabric Link 
and 32GB of HBM2 each, configured with Afterburner and a 4TB SSD. Tested on macOS Catalina, with 
Final Cut Pro 10.4.7, Canon RAW Plugin 1.1.2 for Final Cut Pro X, and plug-ins from RED Apple Workflow 
Installer v14, using 50-second projects with Apple ProRes RAW HQ video, Apple ProRes RAW video, 
REDCODE® RAW 3:1 video, REDCODE® RAW 5:1 video, and Canon Cinema RAW Light video, all at 
4096x2160 resolution and 23.98 frames per second. Performance may vary based on system 
configuration, media type, and other factors.
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Performance
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Testing conducted by Apple in November 2019 on preproduction 2.5GHz 28-core Intel Xeon W-based
Mac Pro systems with 384GB of RAM and dual AMD Radeon Pro Vega II graphics with Infinity Fabric Link 
and 32GB of HBM2 each, configured with Afterburner and a 4TB SSD. Tested on macOS Catalina, with 
Final Cut Pro 10.4.7, Canon RAW Plugin 1.1.2 for Final Cut Pro X, and plug-ins from RED Apple Workflow 
Installer v14, using 50-second projects with Apple ProRes RAW HQ video, Apple ProRes RAW video, 
REDCODE® RAW 3:1 video, REDCODE® RAW 5:1 video, and Canon Cinema RAW Light video, all at 
4096x2160 resolution and 23.98 frames per second. Performance may vary based on system 
configuration, media type, and other factors.
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Testing conducted by Apple in November 2019 on preproduction 2.5GHz 28-core Intel Xeon W-based
Mac Pro systems with 384GB of RAM and dual AMD Radeon Pro Vega II graphics with Infinity Fabric Link 
and 32GB of HBM2 each, configured with Afterburner and a 4TB SSD. Tested on macOS Catalina, with
Final Cut Pro 10.4.7, Canon RAW Plugin 1.1.2 for Final Cut Pro X, and plug-ins from RED Apple Workflow 
Installer v14, using 50-second projects with Apple ProRes RAW HQ video, Apple ProRes RAW video, 
REDCODE® RAW 3:1 video, REDCODE® RAW 5:1 video, and Canon Cinema RAW Light video, all at 
4096x2160 resolution and 23.98 frames per second. Performance may vary based on system 
configuration, media type, and other factors.
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ProRes RAW is an ideal format for creating wide-gamut, high-dynamic-
range (HDR) content because it captures the full dynamic range and 
color gamut of the camera sensor. If you want to create standard-
dynamic-range (SDR) content, such as high-definition broadcast 
(Rec. 709) video, the high dynamic range of a ProRes RAW source file 
must be restricted to a dynamic range suitable for viewing on an SDR 
display. This process is called tone mapping.

There are three primary ways to use ProRes RAW with Final Cut Pro in 
your post-production workflow:

• Using Log Conversion with Built-in Camera LUTs

• Using Log Conversion with Custom LUT Effects

• Grading Directly Without LUTs

For more information about working with HDR in Final Cut Pro, see 
the Final Cut Pro X User Guide and HDR and Wide Color Gamut in 
Final Cut Pro X.

Using ProRes RAW in Final Cut Pro

https://support.apple.com/guide/final-cut-pro/welcome
https://www.apple.com/final-cut-pro/docs/HDR_WideColor.pdf
https://www.apple.com/final-cut-pro/docs/HDR_WideColor.pdf


 13Apple ProRes RAW January 2020

Using ProRes RAW in Final Cut Pro

Using Log Conversion with Built-in 
Camera LUTs
Most professional video cameras today support recording in a log 
format. Using log enables a higher dynamic range of light levels to be 
represented compared to standard video gamma functions. Because 
many color-grading workflows are based on working with log video, 
Final Cut Pro can automatically apply a log conversion setting to 
ProRes RAW media files during import. With log conversion applied, 
ProRes RAW files behave just like conventional log video and can be 
edited the same way.

Using built-in log conversion allows you to color correct ProRes RAW 
video as if it were SDR or HDR video, depending on your library 
color-processing setting. When your library is set to Standard color 
processing, you can color correct ProRes RAW video as if it were SDR 
video. With your library set to Wide Gamut HDR, you can color correct 
ProRes RAW video as if it were HDR video.

RAW to Log Conversion Setting
Decoding ProRes RAW directly results in HDR linear values rather 
than log. The Raw to Log Conversion setting in the Info inspector 
applies custom log functions created by different camera vendors 
so that you can color correct your ProRes RAW files as log video. 
Because ProRes RAW files contain metadata that identifies the camera 
manufacturer, Final Cut Pro can apply the correct log function (such as 
Canon Log 2, Panasonic V-Log, or Sony S-Log3) during import.

You can also manually adjust the RAW to Log Conversion setting in the 
General, Extended, or Settings view of the Info inspector.
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Using ProRes RAW in Final Cut Pro

Change the RAW to Log Conversion setting
1. Select one or more video clips recorded with ProRes RAW.

2. If the Info inspector isn’t already shown, choose Window > Show in 
Workspace > Inspector, then click the Info button at the top.

 

Choose a log 
conversion option.

Click the Info button.

Choose General, 
Extended, or Settings.

3. Click the Metadata View pop-up menu in the bottom-left corner, then 
choose either General, Extended, or Settings.

4. Click the RAW to Log Conversion pop-up menu and choose an option.
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Using ProRes RAW in Final Cut Pro

Camera LUT Setting
A lookup table (LUT) is a set of data that transforms pixel values to 
change the way an image looks. Because log video footage initially 
looks flat, Final Cut Pro can apply a Camera LUT setting to make the 
image look less flat and more vibrant. It essentially converts the log-
encoded image to an image in the intended output color space in a way 
that looks pleasing to the eye. As with all video shot with log encoding, 
Final Cut Pro automatically applies the Camera LUT setting based on 
metadata in the file that identifies the camera manufacturer. You can 
view the Camera LUT setting in the Info inspector.

Camera LUT setting

The type of conversion performed by the built-in camera LUT depends 
on the library color-processing setting. When color processing is set to 
Standard, the log conversion applies tone mapping to reduce the original 
high dynamic range of the log content to a range suitable for SDR video.
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Using ProRes RAW in Final Cut Pro

To make the full dynamic range of the original video available in the 
working color space, change the library color-processing setting to 
Wide Gamut HDR. When color processing is set to Wide Gamut HDR, the 
built-in camera LUT does not apply tone mapping and preserves the full 
dynamic range for color correction and effects.

Set library color processing to Wide Gamut HDR
1. Select a library in the Libraries sidebar.

2. Choose File > Library Properties, then click the Modify button at the 
top of the inspector.

 

Click to set the 
color processing.

3. Select Wide Gamut HDR.

You can add ProRes RAW clips directly to an HDR project in the 
timeline—for example, a project set to Rec. 2020 PQ or Rec. 2020 HLG—
and monitor them using a third-party video interface (such as an AJA 
Io 4K Plus) and an external HDR reference monitor. You can easily 
color correct the clips using the advanced color correction tools in 
Final Cut Pro.
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Using ProRes RAW in Final Cut Pro

Using Log Conversion with Custom 
LUT Effects
This workflow employs a Custom LUT effect (instead of a built-in camera 
LUT) and allows you to color correct ProRes RAW video as though it were 
log video.

Step 1: Change the Camera LUT setting to None
1. Select one or more video clips recorded with ProRes RAW.

2. If the Info inspector isn’t already shown, choose Window > Show in 
Workspace > Inspector, then click the Info button at the top.

 

Choose None.

Click the Info button.

Choose General, 
Extended, or Settings.

3. Click the Metadata View pop-up menu in the bottom-left corner, then 
choose either General, Extended, or Settings.

4. Click the Camera LUT pop-up menu and choose None.

When Camera LUT is set to None, the color correction tools (such 
as Color Wheels and Color Curves) and other effects operate on the 
log-encoded values. No tone mapping is applied to the source, and no 
dynamic range is lost.

Step 2: Apply color correction and any other video effects
For information about color correcting and adding effects in 
Final Cut Pro, see the Final Cut Pro X User Guide.

https://support.apple.com/guide/final-cut-pro/welcome
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Using ProRes RAW in Final Cut Pro

Step 3: Import and apply a Custom LUT effect
You will need to apply a Custom LUT effect (as the last effect in the list) 
using a 3DLUT file that contains the conversion from log to the output 
color space. Custom LUT effects can be purchased and downloaded 
from a variety of sources, or you can create one yourself using 
inexpensive color-grading software or plug-ins.

1. Select a ProRes RAW clip in the timeline.

2. To open the Effects browser, choose Window > Show in Workspace > 
Effects.

3. Select the Color category on the left, then double-click Custom LUT 
to apply the effect to the selected clip.

4. If the Video inspector isn’t already shown, choose Window > Show in 
Workspace > Inspector, then click the Video button  at the top.

5. In the Custom LUT section of the Video inspector, click the LUT 
pop-up menu and choose “Choose Custom LUT.”

Note: If you previously imported a custom LUT, you can choose 
Recent and then choose from a list of recently used Custom 
LUT effects.

6. In the window that appears, navigate to the LUT file you want to 
import, and select it.

7. Click Open.

The LUT you imported appears as the selected LUT at the top of the 
Custom LUT section.

 

Custom LUT

8. Click the Input pop-up menu and choose the color space the LUT 
converts from.

9. Click the Output pop-up menu and choose the color space the LUT 
converts to.

Note: Make sure the Custom LUT effect is the last effect in the 
effects list. If it isn’t, you can simply drag it to the bottom of the list.
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Using ProRes RAW in Final Cut Pro

Grading Directly Without LUTs
This workflow allows you to color correct ProRes RAW video as HDR 
video, regardless of the library color-processing setting.

Change the RAW to Log Conversion and Camera LUT settings 
to None
1. Select one or more video clips recorded with ProRes RAW.

2. If the Info inspector isn’t already shown, choose Window > Show in 
Workspace > Inspector, then click the Info button at the top.

 

Click the Info button.

Choose General, 
Extended, or Settings.

Choose None from 
these two pop-up 
menus.

3. Click the Metadata View pop-up menu in the bottom-left corner, then 
choose either General, Extended, or Settings.

4. Click the RAW to Log Conversion pop-up menu and choose None, 
then click the Camera LUT pop-up menu and choose None.

No tone mapping is applied to the source, and the full dynamic range 
is available in the working space, even in libraries set to Standard color 
processing. Although highlights may initially appear blown out, you 
can correct this using color correction tools, such as Color Wheels and 
Color Curves.
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Apple ProRes RAW is a powerful new tool for recording and creating 
stunning images that preserves quality while maintaining performance. 
Much of the complexity of working with raw is minimized with smart, 
automatic functions that make it easy for novices and experts alike 
to achieve excellent results. Being able to use the raw image sensor 
data directly in Final Cut Pro during post-production gives you more 
control over the processing of the image, including demosaicing, 
linear-to-log conversions, and custom LUTs. Working with ProRes RAW 
in Final Cut Pro with the advanced color correction tools, you can create 
new looks and compelling images to make your material stand out like 
never before.

Conclusion
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